WebSDK issue affecting Cumulocity UI developers | NPM
Incident Report for Cumulocity IoT
Resolved
The issue has been resolved, all versions are available again on npmjs.com.
Posted Jul 10, 2024 - 13:01 CEST
Identified
We are currently facing issues with our NPM releases.

Nearly all old versions of the @c8y/ngx-components package have been removed.

This issue has no impact on any running application. However, it does affect developers of web applications: Building applications using the Web SDK @c8y/ngx-components might result in errors, as NPM might not find the version you are using.

There are currently two workarounds:
1. If you are using a version higher than 1017.0.0, you can update to the latest fix version of the package. For these releases, we are able to publish new fix versions and you can update to this version by adding the ~ (tilde) in front of all @c8y packages in your package.json.

2. You can switch to versions before 1017.0.0 from our resources server. Simply replace the @c8y/ngx-components version with the following URL:
https://resources.cumulocity.com/webapps/ui-releases/c8y-ngx-components-1013.0.111.tgz (replace the version string, “1013.0.111” in the example URL with your currently used GA version.)

We are sorry for the inconvenience and are working hard on a solution together with NPM.
Posted Jul 09, 2024 - 11:47 CEST