Tenant creation not possible
Incident Report for Cumulocity
Resolved
We fixed the issues with tenant creation. Registering new trial tenants is now possible again.
Posted 10 months ago. Jan 24, 2018 - 12:14 CET
Investigating
At the moment creation of new tenants is not possible! No active tenant is affected by this and all services are working normal.

For new customers: We are working on a solution for this issue and let you know, when tenant registration is possible again. We are looking forward to welcome you as a Cumulocity customer, when this issue is solved.
Posted 10 months ago. Jan 19, 2018 - 16:16 CET